Services unavailable
Incident Report for 12Return
Resolved
Services are available again.
Posted 6 months ago. Dec 14, 2018 - 13:31 CET
Investigating
Our European services are unavailable at the moment.
Posted 6 months ago. Dec 14, 2018 - 13:20 CET
This incident affected: Europe environment (Customer Portal, Email Service, API Services, Agent Portal).