Chrome issue
Incident Report for 12return
Resolved
The issue has been resolved by our hosting provider.
Posted Aug 25, 2021 - 18:39 CEST
Identified
We are facing an unexpected issue with using 12Return in the Chrome browser.

Users will see a security warning when they are trying to download the return label. All other browsers function as normal.
Posted Aug 24, 2021 - 17:52 CEST