The North-America environment is currently unavailable
Incident Report for 12Return
Resolved
This incident has been resolved.
Posted Jun 04, 2019 - 07:20 CEST
Monitoring
The Noth-America environment is operation again, we are monitoring the situation.
Posted Jun 04, 2019 - 06:44 CEST
Investigating
Our Engineers are investigating the isseu.
Posted Jun 04, 2019 - 05:47 CEST
This incident affected: North-America environment (Customer Portal, Agent Portal, Email Service, API Services).