Emergency maintenance
Incident Report for 12return
Resolved
The hosting provider has resolved the issue and is further investigating the downtime, all systems are operational again.
Posted Aug 16, 2017 - 05:53 CEST
Investigating
We have detected file storage outage in the North America regions, its currently impossible to create or access shipping labels. The whole North America site has been put in maintenance mode while we try to resolve this with our hosting provider.
Posted Aug 16, 2017 - 05:35 CEST